Архив

< Апрель 2021 >
П В С Ч П С В
      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30    

Вход на сайт

Тэги

Блог Alex Delphine

Здесь я оставляю разные свои мысли.

 

Приветствую вас братья джумловоды!  Я хочу рассказать историю о том как я устранил небольшую неприятность в компоненте Мy Blog 3.0.332.

К своему изумлению я обнаружил что размер вставляемого видео по умолчанию 100x100px! Конечно каждый раз можно прописывать высоту и ширину вручную но это не дело. Да и посетители избалованные супер скриптами социальных сетей не станут заморачиватся и просто уйдут.

Итак, сночало я подумал что размер задаётся плагином Azrul Video Mambot зашёл в админку но там всё правильно : ширина 425px высота 350px. Странно... Тогда я с помощью Total Commander нашёл два файла:

components / com_myblog / templates / admin / write.html
и
components / com_myblog / templates / admin / write.old.html

В каждом из этих файлов есть строчки кода:

<input class="inputbox" id="videoWidth" size="3" value="100" type="text" />
<input class="inputbox" id="videoHeight" size="3" value="100" type="text" />

Цифры 100 и есть размер который даётся видео по умолчанию. Заменил в этих файлах в первой строчке 100 на 425 и во второй 100 на 350. Теперь во всплывающем окне редактора размеры видео по умолчанию 425 x 350px.



Комментарии  

 
0 #1 Ольга 29.08.2010 20:46
Подскажите, у меня не грузится изображения и не добавляется видео. При добавлении изображения выскакивает надпись "Image embed only works in WYSIWYG Editor Mode" Думала что это связано с редактором, поменяла TinyMCE на Jce но не помогло. Еще у меня при активации мамбота "Материалы - Joomthumbnail" перстают грузиться блоги, просто белый лист. Может с этим связано? Зараннее благодарна за ответ.
 
 
0 #2 qwerty 29.08.2010 20:50
Мy Blog работает только с TinyMCE. А видео нужно включить в админке блога. Смотрите настройки блога.
 
 
0 #3 Ольга 29.08.2010 21:38
видео в настройках блога включено, редактор использую TinyMCE, но ни видео, ни изображения не грузятся. При добавлении изображения выскакивает надпись: "Image embed only works in WYSIWYG Editor Mode" а при добавлении видео эта: "A editor instance must be focused before using this command"
 
 
0 #4 qwerty 30.08.2010 19:01
Зайдите в настройках блога во вкладки "Панель управления" и сделайте вот такие настройки

И установите права на папку с картинками блога 777.
Убедитесь что у вас включён плагин Azrul Video Mambot
 
 
0 #5 Ольга 31.08.2010 08:36
Плагин Azrul Video Mambot - включен
Права на папку поменяла на 777
а функция с сжатием у меня вообще отсутсвует, вот скрин http://savepic.ru/1691002.jpg
Еще у меня редактор отсутвует при добавлении записи скрин http://savepic.ru/1695101.jpg Я пробовала менять папку editors, но тогда пропадает половина редактора, joomla 1.5.9 Помогите пожалуйста
 
 
0 #6 qwerty 31.08.2010 16:18
Попробуйте обновить joomla до последней версии или хотя бы папку editors замените на папку из joomla 1.5.20
Если опять ничего не выйдет напишите мне в личку.
 
 
0 #7 Roman 20.09.2010 22:16
У меня при добавлении видео в MyBlog вместо видео надпись:
You need to a flashplayer enabled browser to view this video
Искал в гугле как поправить, но не нашел. Зато увидел, что на многих сайтах (c MyBlog) тоже вместо видео была такая надпись, но сейчас нормально видео показывает. Помогите пожалуйста как можно это исправить.
 
 
0 #8 qwerty 21.09.2010 13:37
Если надпись You need to a flashplayer enabled browser to view this video появляется лишь периодически значит в этот момент недоступен сервис видеохостинга (Ютюб). А если всегда так то убедитесь что у вас установлен флеш плеер.
 
 
0 #9 Roman 21.09.2010 17:13
Спасибо за ответ. Все работает. Я вставлял ссылку не из адресной строки браузера, а из поля формы "Встроить" (на ютубе) - поэтому не работало.
 
 
0 #10 Евгений 14.02.2011 17:28
Спасибо большое, помогло!
 

У Вас не достаточно прав, для того что бы оставлять комментарии.